Page loading, please wait...



The page still doesn't show? Click here
 
BOM Home Biet-O-Matic Forum
  Watched TopicsWatched Topics     FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

BOM Firefox Extension nicht kompatibel

 
Post new topic   Reply to topic    Biet-O-Matic Forum Forum Index -> Patches, Mods & Tools
View previous topic :: View next topic  
Author Message
Anonymous
Guest





PostPosted: 11.06.2009 - 09:58    Post subject: BOM Firefox Extension nicht kompatibel Reply with quote

Ich stelle fest, dass BOM Firefox Extension1.1 nicht kompatibel mit Firefox 3.5b99 ist.

OK mit der 3.1.x bis 3.5b4 war das Teil auch nicht kompatibel, aber b99 heißt nun mal auch RC, da wird's doch langsam Zeit, dass man da eine 0 durch eine 5 ersetzt, evtl. sogar 6 muss mir glatt mal wieder ein aktuelles Minenfeld Wink) besorgen.

Nachdem 1.1 mit etwas "nächlicher" Unterstützung (MR Tech Toolkit geht auch) wunderbar arbeitet sollte es für die 1.1.1 doch vermutlich reichen nur die max Version hochzusetzen 3.5 sollte in jedem Fall gehen, wäre IMHO ganz hilfreich für alle die keine Nightly Tester Tools mitlaufen haben.

Wobei ich insgesamt feststellen muss, dass die Rate der roten Ausrufezeichen bei den Add-Ons in diesem späten Entwicklungsstand immer noch unanständig hoch ist.

Was mich jetzt besonder bei "Kommerziellen" Add-Ons wie Drag & Drop.io stört die haben bei 3.1b1 aufgehört, dabei wollen sie mit ihrem Premiumservice doch Geld verdienen. Ansonsten sind die 100 MB freier Webspace den man dort in beliebiger Anzahl bei http://drop.io einrichten kann aber nicht zu verachten, schließlich kann man die Foto-CD für die liebe Verwandschaft auch in 7 Archive aufteilen.
Back to top
Mæster
Forum Admin
Forum Admin


Joined: 04 Sep 2004
Posts: 2105

PostPosted: 13.06.2009 - 11:23    Post subject: Reply with quote

Quote:
OK mit der 3.1.x bis 3.5b4 war das Teil auch nicht kompatibel, aber b99 heißt nun mal auch RC, da wird's doch langsam Zeit,

Version 1.2 des Plugins ist ab sofort erhältlich und erhöht unter anderem die Kompatibilität auf Firefox Version 3.*. Diejenigen mit bereits installierter Version 1.1 sollten die automatische Addon-Update-Funktion von FF nutzen.

Quote:
Nachdem 1.1 mit etwas "nächlicher" Unterstützung (MR Tech Toolkit geht auch) wunderbar arbeitet sollte es für die 1.1.1 doch vermutlich reichen nur die max Version hochzusetzen 3.5 sollte in jedem Fall gehen, wäre IMHO ganz hilfreich für alle die keine Nightly Tester Tools mitlaufen haben.

Wenn man nur die Kompatibilität eines Addons hochsetzen will, braucht man keine neue Version rausbringen. Es reicht, wenn man die Versionsdaten in der update.rdf anpaszt. Wenn FF eine gröszere maxVersion in der update.rdf findet, wird diese genommen und nicht diejenige aus der install.rdf Wink.

Die update.rdf hats aber inzwischen in sich. Bei normalen http-UpdateUrls musz man erstens den SHA1-Hash der Erweiterung angeben und zweitens musz die update.rdf anschlieszend mit einem vorher generierten Schlüsselpaar signiert werden.

Die FF-Entwickler, die einem derartige Steine in den Weg legen kann ich nur noch als paranoid bezeichnen. Einerseits Addon-Entwickler für eine simple Erweiterung zu SSL-Zertifikaten drängen, andererseits nicht auf sich selbst hören können und den Mozilla-Shop unter einer normalen http-Adresse anbieten, bei dem die Kreditkarteninformationen im Klartext übermittelt werden - die spinnen doch Exclamation

_________________
Grusz,
Mæster.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
blockx
BOM-interessiert
BOM-interessiert


Joined: 20 Dec 2008
Posts: 34

PostPosted: 13.06.2009 - 16:22    Post subject: Reply with quote

Mæster wrote:
Die FF-Entwickler, die einem derartige Steine in den Weg legen kann ich nur noch als paranoid bezeichnen. Einerseits Addon-Entwickler für eine simple Erweiterung zu SSL-Zertifikaten drängen, andererseits nicht auf sich selbst hören können und den Mozilla-Shop unter einer normalen http-Adresse anbieten, bei dem die Kreditkarteninformationen im Klartext übermittelt werden - die spinnen doch Exclamation


https://intlstore.mozilla.org/
Wink
Back to top
View user's profile Send private message
Mæster
Forum Admin
Forum Admin


Joined: 04 Sep 2004
Posts: 2105

PostPosted: 13.06.2009 - 23:13    Post subject: Reply with quote

Quote:
https://intlstore.mozilla.org/

Na dann will ich mal nichts gesagt haben - da hat wohl meine Beschwerdemail des letzen Jahres doch noch was gebracht. Laughing

_________________
Grusz,
Mæster.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
Anonymous
Guest





PostPosted: 14.06.2009 - 10:21    Post subject: Reply with quote

Mæster wrote:

Version 1.2 des Plugins ist ab sofort erhältlich und erhöht unter anderem die Kompatibilität auf Firefox Version 3.*. Diejenigen mit bereits installierter Version 1.1 sollten die automatische Addon-Update-Funktion von FF nutzen.

Quote:
Nachdem 1.1 mit etwas "nächlicher" Unterstützung (MR Tech Toolkit geht auch) wunderbar arbeitet sollte es für die 1.1.1 doch vermutlich reichen nur die max Version hochzusetzen 3.5 sollte in jedem Fall gehen, wäre IMHO ganz hilfreich für alle die keine Nightly Tester Tools mitlaufen haben.

Wenn man nur die Kompatibilität eines Addons hochsetzen will, braucht man keine neue Version rausbringen. Es reicht, wenn man die Versionsdaten in der update.rdf anpaszt. Wenn FF eine gröszere maxVersion in der update.rdf findet, wird diese genommen und nicht diejenige aus der install.rdf Wink.


Ebend, drum hatte ich ja auch 1.1.1 vorgeschlagen, man muss ja der Mozilla-eigenen Versionsnummern-Inflation nicht unbedingt folgen. Der Firefox hätte ruhig bei 3.1 bleiben können, die höhere Nummer hätte er verdient gehabt wenn er beim aktuellen Safari- und Opera-Entwicklungsstand, sprich 100 bei Acid3, gelandet ist.

Mæster wrote:
Version 1.2 des Plugins ist ab sofort erhältlich und erhöht unter anderem die Kompatibilität auf Firefox Version 3.*. Diejenigen mit bereits installierter Version 1.1 sollten die automatische Addon-Update-Funktion von FF nutzen.


Danke für die schnelle Reaktion und Anpassung.

Aber die automatische Aktualisierung hängt noch in der Warteschleife jedenfalls, eben ging da noch nix.

Das heißt aber bei Mozilla nix, den Update der 3.0er auf 3.0.11 musst ich vorhin auch erst per Hand anstupsen (obwohl sämtliche Updatefunktionen ausgewählt sind) und dann hat es schon wieder rumgesponnen, dass es nicht updaten können weil Firefox noch laufen würde (ganz sicher nicht, jedenfalls nicht wenn die Updateroutine die Instanz aus der sie aufgerufen wurde ordentlich schließt und lange genug wartet bis das auch passiert ist, was sie offensichtlich nicht tut). Thunderbird gibt's auch noch und ich vermute mal, das es da durch mitlaufende Add-ons wie Thunderbird-Biff etc. eine Verbindung hergestellt wird. Diese blöde Box, mit der Mitteilung, dass erst alles geschlossen werden muss und man sonst nicht updaten könne nervt einfach nur. Denkende Wesen (Damit ist der Programmierer und nicht das Programm gemeint - aber wie war das - "jedes Programm ist nur so intelligent wie der Programmierer der es erstellt hat - darum gibt es so viele sauschlechte Anwendungen) fragen an dieser Stelle nach ob sie die störenden Prozesse schließen sollen und tun das nach OK dann selbständig.

Mæster wrote:
Quote:


Die update.rdf hats aber inzwischen in sich. Bei normalen http-UpdateUrls musz man erstens den SHA1-Hash der Erweiterung angeben und zweitens musz die update.rdf anschlieszend mit einem vorher generierten Schlüsselpaar signiert werden.

Die FF-Entwickler, die einem derartige Steine in den Weg legen kann ich nur noch als paranoid bezeichnen. Einerseits Addon-Entwickler für eine simple Erweiterung zu SSL-Zertifikaten drängen, andererseits nicht auf sich selbst hören können und den Mozilla-Shop unter einer normalen http-Adresse anbieten, bei dem die Kreditkarteninformationen im Klartext übermittelt werden - die spinnen doch Exclamation



blockx wrote:
Mæster wrote:
Die FF-Entwickler, die einem derartige Steine in den Weg legen kann ich nur noch als paranoid bezeichnen. Einerseits Addon-Entwickler für eine simple Erweiterung zu SSL-Zertifikaten drängen, andererseits nicht auf sich selbst hören können und den Mozilla-Shop unter einer normalen http-Adresse anbieten, bei dem die Kreditkarteninformationen im Klartext übermittelt werden - die spinnen doch Exclamation


ttps://intlstore.mozilla.org/
Wink



Da habt ihr vielleicht beide recht, beim klicken auf den Store aus ww.mozilla.org heraus kommt

ttp://intlstore.mozilla.org

so wie es im Source der Seite auch aufgerufen wird

ttps://intlstore.mozilla.org

geht auch, kommt aber leider nicht standardmäßig und vielleicht schalten sie dann ja bei der Bezahlfunktion um, das kann ich aber nicht testen weil ich da noch nie soweit drin war, schon weil ich ich nie als Werbeträger für irgend jemand durch die Gegend laufe, ich bin keine wandelnde Litfaßsäule und wenn ich eine wäre würde der Platz auf mir was kosten und nicht umgekehrt. Ich hab da grundsätzlich so meine Probleme mit so Aktionen kaufen sie XY und unterstützen sie abc damit, i.d.R. steht da nie in welcher Höhe abc unterstützt wird und wenn doch dann ist der Preis des Grundprodukts überteuert weil man den "guten Zweck" kommerziell ausnutzen will und damit spekuliert, dass ob des guten Zweckes das Gehirn bei manchen Menschen aussetzt. Bessere Methode - Grundprodukt ohne Rücksicht auf Verluste drücken und dann dem guten Zweck direkt was Spenden. Wenn's ein wirklich Guter ist gibt's dafür dann sogar noch eine Spendenquittung für's Finanzamt, beim Produktkauf nicht.

PS: Dieser Beitrag enthält zuviele externe Links. Nervt!! - Wenn die schon beim zitieren entstehen bleibt da nichts mehr übrig. -nach der Erssetzfunktion auch nicht Wink
Back to top
Display posts from previous:   
Post new topic   Reply to topic    Biet-O-Matic Forum Forum Index -> Patches, Mods & Tools All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group